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Draw interface follow the same guiding lines than other Open Office guides. 

 

As it is possible to see on the screen shot, we have 

several toobars that can be turned on and off with View 

→ Toolbars or edited on Tools → Customize → Toolbars 

tab. To the left of the screen we see the "Pages" panel, 

that display a thumbnail of each page existing on the 

document. To the right we have the Sidebar introduced on Apache OpenOffice 4.0, offering 

several tools to create or edit objects. 
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Several buttons on both, the toolbars and the sidebar are drop down menus offering several 

options. 

As shown on the screenshot, these menus have on the bottom a sort of "handler": grabbing 

the menu with the mouse from there and dragging it far from the parent button will create a 

new toolbar with those tools that can be left floating or anchor (or closed) as any other 

toolbar. 

The button corresponding to that menu will reflect the selected tool. 

We will talk about the use of each tool on the corresponding section of this guide, but usually 

they are quite simple to use: just click and drag with the mouse to draw a rectangle, for 

example, or a line. 

When selecting one or more objects, there are several actions available on the right click, like 

aligning, grouping, or even merging and subtracting. 

 

 

 

 

 

 

 

 

All those options will be presented in detail on the section devoted to Draw tools. 
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By default (extensions installed by the user may add new decks and/or panels), the sidebar in 

Draw feature four decks, each one with one or several panels. 

 

The content displayed by Properties deck depends on the selected object. If no object is 

selected, it only display the "Insert Shape" panel 

 

Once an object is selected, several panels are presented below. The panels "Text" and 

"Paragraph" can be used to select font properties and alignment of text associated to an 

object (we will come back to this later). 

For vector inserted graphics, panels to change the properties of the filling and the lines that 

form the object are available as "Area" and "Line" panels. With these panels it is possible to set 

a background either as a solid color, as a picture, gradient or patter, set transparency, 

etcetera. 

For lines it is possible to set an arrow head on either end, decide if at corners lines should be 

rounded, mitered or bevelet, if the line caps are square or rounded, etcetera. 
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The "Position and Size" panel permits to move, resize and rotate any selected object or 

picture. 

If a picture is selected, a panel called "Graphic" will be available. This panel can be used to set 

image contrast or color (turn a picture to black and white, for example), set transparency or 

even modify the color balance or the gamma value. 

The graphic panel do not change the picture, just apply a "mask" to it. The real 
picture is not edited and can be seen again just by turning of the selected filters. 

 

Also in Draw it is possible to define styles to be applied to several objects, controlling the 

appearance and properties of those objects on a centralized way. We will come back to the 

use of styles on Draw on the next section. 

 

The gallery offers a series of pictures, diagrams and sounds ready to be used on any 

document. 

The gallery is also available as standalone panel under Tools → Gallery. 

 

Selecting a theme listed on the top of the deck, you just need 

to drag and drop the selected image into your document, or 

right click → Insert. It is also possible to create a custom 

theme with the New Theme button: just drag and drop the 

pictures you want to add to the gallery either from the 

document or from the file browser of your system to the 

newly created theme. 
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You cannot add objects to existing themes, unless it is the (empty by default) 

theme called "My Theme": you need to either use My Theme or create a new one. 

 

The navigator can be used to browse between pages (called Slides on the navigator) and 

objects inserted on those pages. By default, only those objects with a "name" (right click on 

the object → Name) will be shown on Navigator, but you can choose to also show unnamed 

object as well opening the menu "Show Shapes" to the right of the buttons on top of the 

Navigator. 

There is a problem that do not permit to select unnamed objects from the 
navigator on Draw. See Issue 96488 for more details. The Navigator is also 

available as standalone panel under View → Navigator or  F5 . 

 

Every object or picture can be associated with text: a double click is enough to be able to 

insert text that will remain "linked" to the object. 

The properties of that text can be managed just by selecting it and applying manual 

formatting with the help of the Text and Paragraph panels on the Properties deck on the 

Sidebar, or with the use of the formatting toolbars. With a right click on the object → Text, it 

is possible to set how the text will be aligned with the object, the anchoring point, spacing to 

borders, if it should remain inside the object or not, etcetera. 
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Some options ("Fit width to text" and "Fit height to text") on this menu are only available for 

text boxes. 

Other options ("Word wrap text in shape" and "Resize shape to fit text") are only available for 

non rectangular drawing objects. 

TODO: more detailed description for this options. Description for the "Text animation" tab. 

It is also possible to enter text independently of any object on the drawing, by using the text 

tool (the button with a T): in practice, this insert a box without border line and without 

background and set to change its size to give place to the text. 

Text, as any other property for drawing objects and pictures, can be controlled by the use of 

styles, as we will see on the next section of this guide. 
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Below the working area on a Draw document, it is possible to see by default three "tabs" 

 

Each tab represent a "Layer" on the drawing. Layers are a way to group different object 

inserted to gain more control of all the elements. For example, it is possible to associate all 

dimension lines to the "Dimension Lines" layer while keeping the main elements on the 

"Layout" layer. Or even create a new layer with a right click over the layer name area → Insert 

Layer, calling it, for example, "guiding lines" where simple geometrical objects are inserted to 

guide us on the building of our drawing. 

 

 

 

 

 

 

 

 

The advantage of working this way is that it is possible to make a layer "invisible" with a 

simple right click over it, so every element on that layer will be automatically hidden from the 

resulting drawing. It is also possible to choose that one particular layer do not print or that 
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their elements are locked so they cannot be edited. All those properties are available with a 

simple right click over the layer name → Modify layer 

 

The easiest way to associate an object to a layer, is to select that layer before inserting the 

object. If the object is already there, you need to cut the object by selecting it and issuing Ctrl  

+  X , select the desired layer and then paste the object with  Ctrl  +  C . 

 

Unless the particular layer where the object is inserted get locked, working on an object 

(changing its properties, moving it above or below another, etcetera) do not depends on 

which layer the object was created. Because of this, the only way to tell to which layer the 

object belongs is to select it and look at the Status Bar, at the box where the slide number on 

which we are working is displayed: between parenthesis the name of the layer will be shown. 

For example, on the screenshot over you can read "Slide 1 / 1 (Dimension Lines)", which means 

that we are working on the first and only slide on the document (if it were the second on a 

three slides document, the text would be "Slide 2 / 3") and that the layer where the selected 

object belong is the one called "Dimension Lines": 
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Sometimes, it is necessary to be sure that a set of 

object all have the same set of properties, like 

same background, same line width/color, same 

font for the associated text, etcetera. This 

coherence in formatting object can be easily 

attained with the use of styles. 

The tool to manage and apply styles is the Stylist, 

available either on the Sidebar or as standalone 

panel that opens with  F11 or Format → Styles 

and formatting. Both versions of the Stylist, the 

standalone panel and the corresponding deck on 

the sidebar, work the same way. 

 

 

On top of the Styles and Formatting deck/window, it is possible to find five buttons. The first 

one is for graphic styles. The second one, "Presentation Styles" is greyed out because those 

styles can only be used on Impress: on Draw, there is only one kind of style. The last three 

buttons are: 

 Fill format mode: Selecting a style from the list and then this button, it is possible to 

apply the style to several objects without the need to select the style again each time. 

 New style from selection: applying manual formatting to an object and then clicking 

on that button, a new style will be created with the selected characteristics. 
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 Update style: If you manually modify the properties of an object and then click that 

button, the style associated with that object will be updated with the changes. 

By updating a style this way, the formatting of all object that use that style will be 
updated too. 

 

The area below those buttons show a list of the available styles. With a right click it is possible 

to either edit an existing style or to create a new one. 

 

Below the list of styles, a menu offers the possibility to "filter" the styles: 

 Hierarchical: As in Writer, styles can depend on others, sharing some characteristics. 

This filtering mode will show all the available styles evidencing which style depends 

on which one. 

 All Styles: will display all existing styles. This is the default view. 

 Applied Styles: display only the styles actually used on the document. 

 Custom Styles: display only those styles created by the user. 

 

Selecting an object and double clicking the style name on the stylist, the style will be applied 

to that object. It is also possible, as commented above, to select a style from the list, then click 

on the "Fill format mode" button and then clicking on the selected objects. To exit the fill 

mode, just press  ESC  or again the "Fill format mode" button. 
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Either by editing an existing style or by creating a new one, a window with several tabs is 

presented. 

 

 

Here it is possible to give a name to the style and define to which style it is linked. The linking 

of styles is useful when it is needed to have several styles that share some options (for 

example, font used and its size for the associated text, line style and color) but not others (for 

example, background color). Selecting a "parent" style and only modifying those parameters 

that need to be different a high coherence can be attained. If afterwards we need to change 

some of those shared settings, we only need to edit the parent style and all the "child" styles 

will be updated automatically. 

 



 

 

 

   
"Transmedia: a new narrative that involves communication and education towards the future classroom”. Code: 2014-1-ES01-KA201-004478 

This project has been funded with support from the European Commission. This publication reflects the views only of the author, and the 
Commission cannot be held responsible for any use which may be made of the information contained therein. 

This work is licensed under a Creative Commons Attribution-NonCommercial-NoDerivatives 4.0 International. Permissions beyond the scope of this 
license may be available at educationtransmedia@gmail.com 

    15 

To define all properties of lines, either for line objects (Bézier curves, lines, etcetera) as well as 

boundary lines for two dimensional objects like squares, ellipses, etcetera. Here it is possible 

to set the line color, its transparency, its width or its style (continuous, dotted, etcetera). 

For open lines it is possible to set arrowheads on their extremes or set if the line will end flat or 

round (under "Corner and cap styles" → "Cap style"). 

If a line show an angle, it is possible to decide if that angle will be rounded, mitered or bevelled 

(under "Corner and cap styles" → "Corner style"). 

 

For closed objects like squares, ellipses, closed polygons, etcetera, it is possible to define a 

background. 

The menu "Fill" permits to select between several options 

 None: No background. The object will behave as "empty. 

 Color: A solid color as background. All colors defined on Apache OpenOffice are 

available to be selected. 

 Gradients: One of several predefined gradients. 

 Hatching: Select a pattern. It is possible to also set a background color to be 

combined with the pattern. 

 Bitmap: Set a picture as background. 
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It is possible to set a "shadow" for Draw objects. This shadow is build as a copy of the original 

object with a different color and shifted in position. Here it is possible to set default shadows 

for objects using the style, select the color for the shadow, the displacement from the object, 

its transparency, etcetera. 

 

Transparency for all object using the style. The transparency can be set as an uniform value or 

as a gradient, with different values of transparency for different points of the object. 

 

This menu is identical to the corresponding menu for paragraph and character styles on 

Writer. 

 

This menu is identical to the corresponding menu for paragraph and character styles on 

Writer. 

 

This menu is identical to the corresponding menu for paragraph and character styles on 

Writer, except for the "Register true" option that it is not present. 
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The options available on this tab were already described on a previous section 

 

The options available on this tab were already described on a previous section 

 

The options on this tab are exactly the same you find by manually editing the properties of a 

size line. This options are then described on detail on the corresponding section for Draw 

tools. 

 

As the name suggests, connectors are used to connect two objects in Open Office Draw using 

a simple tool called a connector. They can be found in the lower tab of a draw software: 

 

 

There are 12 different types of connectors in Draw. One can use them in whichever style suits 

best. They are as follows: 
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To use a Connector: 

1. Go to the connector tool. 

2. Select from the various styles options in the box 

3. Bring your cursor to the page and draw it out. 

Connectors can be dragged and stretched in any direction to get the maximum customization 

for connecting two objects no matter how close or far apart they may be. 
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Connectors can be used as they are given and can also be modified and customized to a large 

extent with the help of tools available in draw. Following are the different tools used to 

customize them. 

 

The shadow effect is essentially that. It provides a shadow to the connector for added 

graphics/design purposes. It is on the top right side of the toolbar. 
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For the shadow effect: 

1. Click on the image of connector. 

2. Find the shadow tab on the top right of the draw toolbar and click on for the desired 

shadow effect to show up. 

In the image below red and green connectors have been given the shadow effect. 

 

 

 

 

 

 

 

 

 

A line style is a way of styling the connector line which is either continuous, dotted, 

combination of both, dashed, etc. Line style tool can be found on the top left side of the 

toolbar in Draw. 

 

Draw has 13 different line styles. 
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One can choose from among any of these and apply it to the connectors as follows: 

1. Select the connector to be styled 

2. Go to the line style tool and select desired style 

3. See the effect show up 
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Line width can be found on the top left of the Draw toolbar: 

 

Line width changes the width of the connector line to suit one's specifications. To change the 

width of aconnector: 

1. Select the connectors 

2. Increase or decrease width using top and bottom arrows respectively to get the 

desired width 
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Corner and cap styles is present in the line tool on the top left of the toolbar. They have 

different attributes to choose from and can be applied to the connector depending on the 

user's preference. 
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Line colour tool can be found on the top left side of the top toolbar: 

 

 

Line colour tool changes the colour of the connector to match colours of connecting objects. 

1. Select the connector to be coloured 

2. Click on the line colour tool and choose the desired colour. 

3. The colour will show up on the connector. 
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Once, the colour has been decided. The transparency a connector can be changed in the 

amount of percentages. Transparency tool can be found in the Line function on the top left of 

the tool bar. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The above image is changed to allow 50% transparency. 
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This tool can be found on the top left side of the the top toolbar: 

 

 

 

 

 

 

 

 

 

Draw offers 15 different arrow styles for connectors. They are as follows: 

 

While a connector can have the same arrow style for both its 

endpoints, it can also have two different styles at the same time. 

Select the connector to be styled. Select an arrowhead. The 

arrowhead of one point of the connector will be changed. To 

change the other; follow the same procedure and the result will 

show up. 
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Any amount of text can be added within connectors to give more information about how the 

two objects are related /connected. For adding text, simply double click on the connector and 

a cursor will appear blinking. Start writing your text and it will automatically align it to the 

center as you fill in more characters. Text between connectors can be given the same 

attributes that a normal text is entitled to. For e.g. Bold, underlined, italicized, change of font 

color, change of font size, etc. 

 

Connectors can be styled endlessly using all of the above given tools. 
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Measuring Distances on Apache OpenOffice DrawDraw offers a tool to measure distances on 

a graphical way. This tool can be selected from the Sidebar, under "Insert Shapes" panel on 

Properties deck, opening the "Lines and arrows" menu 

 

This allows to draw a line that will show its size. With a right click on the resulting line, it is 

possible to edit its properties. 

It is also possible to define these properties on a style. 

This properties only change how the measurement is presented. To change the line properties 

(color, width, continuous or dotted...) the same procedures to set lines needs to be used. 

On this menu, under "Line" it is possible to define how the lines at both ends of the double 

arrow are present, it size, how much they need to go over the double arrow ("Guide overhang" 

option), how much below ("Guide distance" option), how far the measurement line must be 

from the measured point ("Line distance" option). 
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Under "Legend" it is possible to set where the measurement needs to be displayed. For 

greater control, the "AutoVertical" and/or "AutoHorizontal" options must be disabled. 

 

 

 

Bézier curves are common on vector drawing programs and are built giving a series of points, 

the slope to both sides of each point and how "flat" the curve is there. The way Bézier curves 

are implemented in Draw is a bit different from other vector drawing programs like Inkscape, 

but it is not difficult to master. 
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The curve in the figure was build with three points, the central displaying the slope controls. If 

we build the curve following the arrow, we can call the bar a as "former slope control" and the 

b bar as "later slope control". 

First of all, we need to select the Bézier tool       (the icon could be different depending 

on the icon set selected under Tools → Options → OpenOffice → View → Icon size and style) 

and trace the curve following the steps below (each point on the list reflects the number on 

the picture below, the black arrow is the "real" curve while the red arrows show the movement 

of the mouse): 

1. One click, without releasing the mouse button, on the starting point 

2. Move the mouse on the direction of the later slope control for that point and release 

the mouse button 

3. Click, again without releasing the mouse button, on the next point 

4. Move the mouse on the direction of the former control for that point and release the 

button 

5. Repeat points 3 and 4 until the curve is completed 

6. A double click on the last point or the initial will end the process (on the last case, the 

curve will be closed). 
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From the second point the "later control" is not specified. This point is automatically set on 

the opposite direction to the "former control". 

Playing with the "Edit points" toolbar, it is possible to add, remove or move points, cut or 

"break" the curve, separating the controls behaviour to obtain angles. 
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Based on https://wiki.openoffice.org/wiki/Documentation/UserGuide/Draw/Intro 

This work is licensed under a Creative Commons 
Attribution - Non Commercial - No Derivatives 4.0 
International. 
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