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Coordinators: Nicolau Joao Gonçalves Borges & Carla de Jesus 

 

 DIMOTIKO SCHOLEIO DROSIAS K.A’ (Larnaca, Cyprus)                
http://dim-drosia-ka-lar.schools.ac.cy/ 
Coordinator: Stella Eliadou 

 

 COLEGIUL NATIONAL 'B.P. HASDEU' (Buzau, Romania)               
http://bphasdeu.ro/ 
Coordinator: Viorica Raicu  

 

 PAGKYPRIO LYKEIO LARNACA (Larnaca, Cyprus)                  
http://lyk-pagkyprio-lar.schools.ac.cy/ 
Coordinators: Filitsa Filipou Masonou & Konstantia Mala  

 

mailto:educationtransmedia@gmail.com


 

 

 

   
"Transmedia: a new narrative that involves communication and education towards the future classroom”. Code: 2014-1-ES01-KA201-004478 

This project has been funded with support from the European Commission. This publication reflects the views only of the author, and the 
Commission cannot be held responsible for any use which may be made of the information contained therein. 

This work is licensed under a Creative Commons Attribution-NonCommercial-NoDerivatives 4.0 International. Permissions beyond the scope of this 
license may be available at educationtransmedia@gmail.com 

    3 

 INSTITUTO TECNICO INDUSTRIALE STATALE 'GALILEO GALILEI' (Livorno, Italy) 
http://www.galileilivorno.gov.it/ 
Coordinators: Federico Agen & Maddalena Degan  

 
 
 
 
 

Index 
 

 

Chapter 1. Main options for writer        6 

1.1. Writer’s User Interface        6 
1.1.1. Introduction 
1.1.2. Title Bar 
1.1.3. Menu Bar 
1.1.4. Toolbars 
1.1.5. Sidebar 
1.1.6. Ruler 
1.1.7. Status Bar 

 

1.2. Writer’s Sidebar      13   
 

1.3. Starting a New Document     14 
1.3.1. From the Operating System Menu 
1.3.2. From the Quickstarter 
1.3.3. From the Start Center 
1.3.4. From a Template 
1.3.5. Shortcuts 

 

1.4. Opening a Document      15 
1.4.1. From the Start Menu 
1.4.2. From an Open Document 

 

1.5. Saving a Document      17 
1.5.1. Saving a New Document 
1.5.2. Saving Automatically 
1.5.3. Saving as a Microsoft Word Document 

mailto:educationtransmedia@gmail.com


 

 

 

   
"Transmedia: a new narrative that involves communication and education towards the future classroom”. Code: 2014-1-ES01-KA201-004478 

This project has been funded with support from the European Commission. This publication reflects the views only of the author, and the 
Commission cannot be held responsible for any use which may be made of the information contained therein. 

This work is licensed under a Creative Commons Attribution-NonCommercial-NoDerivatives 4.0 International. Permissions beyond the scope of this 
license may be available at educationtransmedia@gmail.com 

    4 

 

1.6. Closing a Document      18 
 

1.7. Writer’s Document Views     18 
1.7.1. Print Layout 
1.7.2. Web  Layout 
1.7.3. Full Screen 

 

1.8. Getting Help in Writer      20 
1.8.1. Help Files 
1.8.2. Tool tips 
1.8.3. Menu Search 

 

Chapter 2. Working with text      22 

2.1. Selecting text       22 

2.1.1 Selecting items that are not consecutive 

2.1.2 Selecting a vertical block of text 

 

2.2. Cutting, copying and pasting text    23 

 

2.3. Numbered and bulleted lists     25 

2.3.1 Using the Bullets and Numbering Toolbar 

2.3.2 Nested Lists 

       

2.4. Auto Text       27 

2.4.1 Inserting an Auto Text 

2.4.2 Defining an Auto Text 

2.4.3 Editing an Auto Text 

2.4.4 Print a list of Auto Text 

mailto:educationtransmedia@gmail.com


 

 

 

   
"Transmedia: a new narrative that involves communication and education towards the future classroom”. Code: 2014-1-ES01-KA201-004478 

This project has been funded with support from the European Commission. This publication reflects the views only of the author, and the 
Commission cannot be held responsible for any use which may be made of the information contained therein. 

This work is licensed under a Creative Commons Attribution-NonCommercial-NoDerivatives 4.0 International. Permissions beyond the scope of this 
license may be available at educationtransmedia@gmail.com 

    5 

 

2.5. Find and replace text      29 

2-5.1  Find an replace specific formatting  

2.5.2 Find and replace paragraph styles 

2.5.3 Using regular expressions (wildcards) 

 

2.6. Inserting special characters     33 

2.6.1 Non-breaking spaces and hyphens 

2.6.2 En and em dashes 

 

2.7. Formatting Paragraphs      35 

2.7.1 Aligned and justified text 

 

2.8.  Formatting characters      37 

 

2.9. Autoformatting text      38 

 

 2.10. Using footnotes and endnotes     39 

  2.10.1  Inserting footnotes and endnotes 

  2.10.2 Defining the format of footnotes and endnotes 

 

 2.11. Checking spelling and grammar    41 

 2.12. Using built-in language tools     43 

  2.12.1 Using language settings in Options 

mailto:educationtransmedia@gmail.com


 

 

 

   
"Transmedia: a new narrative that involves communication and education towards the future classroom”. Code: 2014-1-ES01-KA201-004478 

This project has been funded with support from the European Commission. This publication reflects the views only of the author, and the 
Commission cannot be held responsible for any use which may be made of the information contained therein. 

This work is licensed under a Creative Commons Attribution-NonCommercial-NoDerivatives 4.0 International. Permissions beyond the scope of this 
license may be available at educationtransmedia@gmail.com 

    6 

  2.12.2 Using paragraph and character styles 

  2.12.3 Using the tools → Language menu 

  2.12.4 Using the status bar 

 

2.13. Using synonyms and the thesaurus    45 

2.14. Hyphenating words      46 

2.14.1 Automatic hyphenation 

2.14.2 Manual hyphenation 

 2.15 Word completion      49 

 2.16 Line numbering      50 

 2.17. Tracking changes      51 

2.17.1 Recording changes 

2.17.2  Accepting or rejecting changes 

  2.17.3 Merging modified documents 

  2.17.4 Comparing documents 

2.18. Comments       54 

2.19. Word Count       55 

2.20. Changing Case       55 

 

 

 

 

mailto:educationtransmedia@gmail.com


 

 

 

   
"Transmedia: a new narrative that involves communication and education towards the future classroom”. Code: 2014-1-ES01-KA201-004478 

This project has been funded with support from the European Commission. This publication reflects the views only of the author, and the 
Commission cannot be held responsible for any use which may be made of the information contained therein. 

This work is licensed under a Creative Commons Attribution-NonCommercial-NoDerivatives 4.0 International. Permissions beyond the scope of this 
license may be available at educationtransmedia@gmail.com 

    7 

Chapter 1. Main options for Writer 

 

1.1 Writer’s User interface 

Writer is the word processor of the Apache OpenOffice suite and allows you to create high 

quality press-ready documents with crisp graphics, convert them effortlessly to PDF as well as 

other popular formats using built-in components, all from a great variety of platforms. 

Writer has a very powerful styles feature that allows you to automate complex tasks and helps 

you keep consistency throughout your document. We will discuss styles in the next section. 

Before discussing how to automate tasks or style your documents we need to learn the 

different options for inserting content into a Writer document. 

 

1.1.1. Introduction 

When you open the Writer window, the document will be displayed by default in the view 

option "Print Layout". This view displays similar to the output of the document. The difference 

between what is shown on screen and what is printed relates to the borders displayed and 

objects inserted automatically, as discussed below. 
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 Borders: All borders, such as the text area border, the cell borders on a table, or OLE 

object borders will show in grey to help the author during editing. Those borders will 

not be printed nor exported to PDF. It is possible to change the color of those borders 

(or eliminate them completely). To change border displays, choose Tools → Options 

→ OpenOffice → Appearance and adjust settings under "Text boundaries", "Object 

boundaries" and "Table boundaries". 

 Objects inserted automatically: Objects such as the table of contents and the fields 

show a grey background. Again, this background is not printed nor exported to PDF 

and it is there only during editing. To modify that background, in the same 

Appearance menu there are separate options for "Field shadings" and "Index and table 

shadings". 

As already discussed in the chapter Apache OpenOffice User Interface, there are many menus 

and toolbars that make up the interface of OpenOffice components. In this section, we will 

show you the unique aspects of the OpenOffice Writer interface. 
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1.1.2. Title Bar 

The title bar is located at the top of the window (below the menu bar on Mac), and displays 

the file name of the current document. The default file name for a new document is Untitled 

X, where X is a number dependent on how many documents are open. 

 

1.1.3. Menu Bar 

The Menu bar is located below the title bar (above the title bar on Mac). The functions of the 

menu bar were already discussed in Apache OpenOffice User Interface. Each menu contains a 

drop down submenu with commands specific to the menu title. 

 

1.1.4. Toolbars 

Writer has two types of toolbars, docked and floating, as explained in Apache OpenOffice 

User Interface. 

Important toolbars to note in Writer are the standard toolbar and the formatting toolbar. 

Under the menu bar is the standard toolbar, it provides basic operations such as open, save, 

print, cut, paste, and help, among others. The formatting toolbar is below the standard 

toolbar, it shows tools based on the cursor's selection. For example, when the cursor is on text 

the tools are for formatting text, when the cursor is on a graphic the tools are for formatting 

graphics, and so forth. 

To display or hide toolbars, choose View → Toolbars, and click the name of a toolbar. More on 

moving and editing toolbars in Apache OpenOffice User Interface 

 

1.1.5. Sidebar 

The sidebar is a new feature in OpenOffice 4.0, the sidebar provides frequently used tools, 

grouped in decks. Read more about the sidebar in Apache OpenOffice User Interface. 
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1.1.6. Ruler 

Writer automatically provides a ruler on the horizontal and vertical axis of the document 

window. The ruler displays the dimensions of the page, position of tabs, indents, borders and 

columns. 

To show or hide the ruler, choose View → Ruler. For more ruler display options choose Tools 

→ Options → OpenOffice → View. 

 

From here, tab over to  General to set measurement and spacing of default tab stop intervals. 

 

 

You can also change the measurement unit of the ruler by right clicking on the ruler to open a 

menu of units. 
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To define indents and tab settings, choose Format → Paragraph → Tabs. Create a new tab 

by typing in the position, selecting type and fill, and clicking New. 

 

 

 

 

 

 

 

 

 

 Please note, defining tabs using paragraph styles may be easier and faster for 
your needs. Go to Paragraph and character styles to learn more. 

 

 

1.1.7. Status Bar 

The status bar is located at the bottom of the window. It displays information about the 

document and provides an easy way to change some document settings. 
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 Page Number 

Displays the current page number, sequence number of the current page (if different), and the 

total number of pages in the document. 

If any bookmarks are created in the document, a right click on this field will display the list of 

bookmarks, click on desired one to go to the bookmark. 

You can also access the Navigator by double clicking on this field (more on The Navigator). 

 

 Page Style 

Displays the current page style. To change, right click and choose preferred style from the 

menu. Or double click to bring up the page style dialog box. 

 

 Language 

Displays language for the current document. Click to open a menu for adjusting the language 

settings of selected text or cursor location. Choosing None (do not check spelling) will 

exclude text from spell check and choosing More... will open the character dialog box. 

 

 Insert mode 

Click to toggle between INST (Insert) mode and OVER (Overwrite) mode. Insert mode will 

insert text after the cursor position moves forward. Typing in overwrite mode replaces text 

after the cursor position. 

 

 Selection mode 

Click to toggle between STD (Standard), EXT (Extend), ADD (Add), and BLK (Block) modes. 

These selection modes are explained in Working with Text. 
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 Unsaved changes 

An asterisk (*) appears if changes are not saved. 

 

 

 

 

 Digital signature 

If document has been digitally signed, an icon             shows here. Double click this field to view 

the certificate. 

Note: A document can only be digitally signed after it has been saved. 

 

 Selection and object information 

When the cursor is in a section, heading, list item, or an object is selected, pertinent 

information is displayed. Double-clicking opens the relevant dialog box. 

 

 View 

Click to change between single page, side-by-side and book layout views. 

 

 Zoom 

Drag the zoom slide to change magnification or click on the  +  or  -  buttons to increase or 

decrease magnification. Right click on the zoom percent level field to change the value. 

 

 

mailto:educationtransmedia@gmail.com


 

 

 

   
"Transmedia: a new narrative that involves communication and education towards the future classroom”. Code: 2014-1-ES01-KA201-004478 

This project has been funded with support from the European Commission. This publication reflects the views only of the author, and the 
Commission cannot be held responsible for any use which may be made of the information contained therein. 

This work is licensed under a Creative Commons Attribution-NonCommercial-NoDerivatives 4.0 International. Permissions beyond the scope of this 
license may be available at educationtransmedia@gmail.com 

    14 

1.2. Writer’s Sidebar 

We already introduced the Sidebar in the previous section on the new Apache OpenOffice 

user interface. The Writer sidebar consists of four decks, each with corresponding icons on the 

panel to the right of the sidebar. The decks are described below: 

 Properties: Contains tools for direct formatting within the document. The tools are 

separated into three submenus. 

o Text: Modify text by the font type, size, color, weight, style and spacing. 

o Paragraph: Style the paragraph by alignment, lists or bullets, background 

color, indent, and spacing. 

o Page: Format the page by orientation, margin, size, and number of columns. 

Note that on Writer by changing the options on this panel you'll change the page style 
in use, modifying not only the current page but all pages using the same page style. 
Read more aboutpage styles on Writer. 

 Styles and Formatting: Manage the styles used on the document, applying existing 

styles, creating new ones or modifying them. This deck is also a floating toolbar that 

can be accessed from Format → Styles and Formatting. More about the Styles and 

Formatting tool in Styles on Apache OpenOffice Writer. 

 Gallery: This deck allows you to add images and diagrams included on the Apache 

OpenOffice library. The Gallery displays as two sections, the first lists the images by 

name (Arrows, Background, Diagrams, etc.) and the second displays the images on 

the selected category. With the  New Theme  button you can create new categories. 

To insert an image, or add a new image to the gallery, just drag and drop the selected 

image. This deck is also a floating toolbar that can be accessed from Tools → Gallery. 

 Navigator: Browse the document and reorganize its content by selecting different 

content categories, such as headings, tables, frames, graphics, etc. This deck is also a 

floating toolbar that can be accessed from View → Navigator. Learn more about the 

Navigator. 
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1.3. Starting a New Document 

1.3.1. From the Operating System Menu 

When OpenOffice was installed on your computer, a menu entry for each component was 

added to the system menu. 

Find Writer by going to Start → Programs → OpenOffice → OpenOffice Writer. On Mac, the 

components are accessed through the OpenOffice icon  in the Applications folder. 

Double click the icon to open the Start Center. 

 

1.3.2. From the Quickstarter 

The Quickstarter is an icon placed in the system tray or dock that indicates that OpenOffice 

has been loaded and is ready to use. You can right click the Quickstarter OpenOffice icon to 

open a pop-up menu from which you can open a new document, choose from a Template or 

choose an existing document to open. You can also right click the Quickstarter OpenOffice 

icon to open the Start Center. 
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1.3.3. From the Start Center 

If no document is open on OpenOffice, you can 

access the Start Center from the operating 

system menu or the Quickstarter icon. 

Open Writer by choosing Text Document or click 

the Templates          icon to choose a document 

template. 

 

1.3.4. From a Template 

You can use a template to create a new document in Writer. A template is a set of predefined 

styles and formatting and can serve as a foundation to ensure documents follow a certain 

layout. The new OpenOffice installation does not contain many templates. Additional 

templates can be downloaded from http://templates.openoffice.org/. 

 

1.3.5. Shortcuts 

With OpenOffice open,  Control  +  N  brings up the Start Menu. 

With Writer open,  Control  +  N  opens a new text document. 

 

1.4. Opening a Document 

1.4.1. From the Start Menu 

You can open a document from the Start Menu by selecting the  Open  button, which will 

bring up the open dialog box, from which you can select your document. Alternatively, you 

can select and hold the  Open  button to choose from a list of recently used documents. 
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1.4.2. From an Open Document 

 Choose File → Open 

 Click the Open              icon on the standard toolbar. 

 Press  Control  +  O . 

The open dialog box will appear. Select the file you wish to open and click  Open , the file will 

open in a new window. When choosing files you can filter by filetype such as .odt, .doc, or .txt. 
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1.5. Saving a Document 

1.5.1. Saving a New Document 

To save a new document you can do any of the following: 

 Choose File → Save 

 Choose File → Save as 

 Click the Save  icon on the standard toolbar 

 Press  Control  +  S  

These actions will open the save as dialog box, from which you can enter the filename, verify 

the filetype and destination location, and click  Save . 

To save a current document with the same filename, choose File → Save. 

 

1.5.2. Saving Automatically 

Writer will save the document automatically at default time intervals. Automatically saving 

will overwrite the last saved state of the file, just like manual saving. To change the settings 

for autosave: 

1. Choose Tools → Options → Load/Save → General 

2. Choose the time interval under Save AutoRecovery information every ... 

3. Click  OK  when done. 
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1.5.3. Saving as a Microsoft Word Document 

You have the option to save your OpenOffice ODT document in several other available 

formats. Exchanging your OpenOffice ODT files with Microsoft Word users is a common issue. 

The ODT file format is not compatible with Microsoft Word. 

Microsoft Word users can install an ODF Add-In for MS Office to allow files to be recognized, 

but the user may also be unwilling or unable to do so to open the ODT file. It may be easier for 

you to save your document in a word format instead. 

   First, save your file as ODT, otherwise all changes will appear on the MS Word 

version and the ODT version will be lost. 

   Choose File → Save as 

   Choose the Microsoft Word format you wish to save to, and click Save . 

Changes made to the saved document will be saved in MS Word format. To return to ODT you 

must open the document again. 

To have Writer save documents by default in the Microsoft Word file format, go to Tools → 

Options → Load/Save → General. In the section named Default file format, find Document 

type and then select Text document. Under Always save as, select your preferred file 

format. 

 

1.6. Closing a Document 

 Choose File → Close 

 Click the Close icon in the top right hand of the document window. 

If the document has not been saved since the last change, a dialog box will appear asking if 

you want to save your changes. Choose Save to save the changes, Discard to close the 

document without saving changes, or Cancel to abort closing the document. 

 

1.7. Writer’s Document Views 

Writer has three document views available: Print Layout, Web Layout, and Full Screen. 

To change the document view, select the View menu and choose the desired view option. 
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1.7.1. Print Layout 

Print Layout is the default view. You can use the zoom slider to adjust magnification and view 

layout icons in the status bar to change page view. You can also choose View → Zoom to 

adjust view and zoom options in the Zoom & View Layout dialog box. 

 

 

1.7.2. Web Layout 

In Web Layout view you can use the zoom slider but the layout icons are disabled. The Zoom 

& View Layout dialog box only allows zoom options. 

 

1.7.3. Full Screen 

In Full Screen mode the document is displayed in the selected view (Print or Web) but the 

document fills the entire screen. Toolbars and sidebar are not displayed. 

Press  Esc  or the Full Screen icon                                   to exit Full Screen mode. 

 

1.8. Getting Help in Writer 

Writer provides several forms of help. You can choose from the full Help File, tool tips, and 

menu search. 
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1.8.1. Help Files 

To access the Help files press  F1  or choose Help → OpenOffice Help or click the Help icon          

in the  standard toolbar. 

These actions will bring up the OpenOffice Help dialog box. You can search the help file pages 

and bookmark pages with the Add to Bookmarks icon . 

 

 

 

 

 

 

 

 

 

 

1.8.2. Tool tips 

To use tool tips, choose Help → What's This?. Hover the cursor over any of the icons in 

Writer, and a tool tip will appear, providing an explanation of the icon's function. 

 

 

 

 

1.8.3. Menu Search 

To search for a function or see a menu navigation, choose Help → Search and enter your 

search term. Writer will display menu directions to the tool, and a list of related help files. 
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Chapter 2. Working with text 

 

2.1. Selecting text 

In Writer, in order to work with text, you need to select it. Selecting a piece of text, or 

consecutive pieces of text, is relatively simple. 

Using the cursor, left click the text, and drag until the desired text is selected. You can also use 

selection shortcuts by left clicking the text. Single words can be selected with a double left 

click, a sentence selected with a triple left click, and a paragraph selected with a quadruple left 

click. 

With the keyboard, use the navigation arrows to choose the text, hold down the  ⇧ Shift  key 

and select text area with the arrow keys. 
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To quickly select content on the entire page, press Control  +  A , or go to Edit → Select All 

 

2.1.1 Selecting items that are not consecutive 

 Using the cursor, select the first piece of text. 

 Hold down the Control key (continue holding until all selections are complete), and 

use the cursor to select the next piece of text. 

 Repeat until all selections are made. 

 

 

 

2.1.2 Selecting a vertical block of text 

Text may be separated by spaces or tabs in a vertical block. To select text in this form, change 

the selection mode to block by choosing Edit → Selection Mode → Block Area or left click on 

STD in the status bar until it changes to BLK. 
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Now you can make your selection as you would with consecutive text selection. 

 

 

2.2. Cutting, copying and pasting text 

Text can be moved within a document, or between documents by cutting or copying and 

subsequently pasting the text. 

Cutting text entails removing it entirely and relocating it within the document. Copying text 

creates a duplicate to be placed within the document. 

 

To cut or copy (with text selected) you can use: 

 Keyboard shortcuts:  Control  +  X  (cut) or  Control  +  C  (copy) 

 Menu selections: Edit → Cut or Edit → Copy 

 Contextual menus: Right click text selection and choose Cut or Copy 

 Icon sources:            Cut or            Copy 

 

Pasting text places the cut or copied text in the document. When pasting text, the formatting 

result depends on the source and how you paste it. 

To paste and retain original formatting use: 

 Keyboard shortcut:  Control  +  V  

 Menu selection: Edit → Paste 

 Contextual menu: Right click and choose Pas    

 Icon source:               Paste 
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To paste and take on formatting of the surrounding text: 

 Choose the arrow to the right of the paste icon, and choose Unformatted text 

 

 

 

 

 Select Edit → Paste Special → Unformatted text 

 

For other paste formatting options, choose from the drop down menu of the paste icon or the 

Paste Special dialog box. 

 

 

2.3. Numbered and bulleted lists 

There are several ways to create numbered or bulleted lists: 

 Auto-formatting (covered later in this chapter) 

 List Styles (covered in the chapter on Styles) 

 The Numbering   and Bullets   icons on the paragraph formatting toolbar. The use of 

these icons will be described in the section below. 
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It is important to note that it is better to avoid the use of numbered list in 

numbered chapters. In another section of this guide we will see how to number 

chapters and give an outline to a document. 

 

To produce a numbered or bulleted list, select the paragraphs in the list and choose the 

appropriate icon. 

 

 

 

 

 

2.3.1 Using the Bullets and Numbering Toolbar 

With a numbered or bulleted list active, a contextual toolbar will open. 

 

 

 

 

 

The buttons, numbered on the screenshot, perform the following actions: 

1. Bullets ON/OFF 

2. Numbering ON/OFF 

3. Numbering OFF 

4. Promote one level 

5. Demote one level 

6. Promote one level with sub-points 
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7. Demote one level with sub-points 

8. Insert an unnumbered entry 

9. Move line up 

10. Move line down 

11. Move line up with sub-points 

12. Move line down with sub-points 

13. Restart numbering 

14. Bullets and Numbering dialog box 

 

The options in the Bullets and Numbering dialog box are the same as when editing a list style, 

so these properties will be covered in the chapter on List Styles. 

 

2.3.2 Nested Lists 

As mentioned earlier, list sub-points refer to the levels of a numbered list or bullet, see 

example below: 

1. First 

1. Sub First 

2. Second 

1. Sub Second 

1. Sub Sub Second 

 

To change the level of one line in the list, either use the Promote/Demote Level                    

icons in the Bullets and Numbering toolbar, or place the cursor at the beginning of the line and 

press  Tab ⇆  or  ⇧ Shift  +  Tab ⇆ . 
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2.4. Auto Text 

Use AutoText to insert text, tables, fields and other items for reuse, by assigning a key 

combination to the item for retrieval. 

For example, by typing dt and  F3 , a long paragraph with a sample text will insert into the 

document (note: dt stands for dummy text and different acronyms may apply to non-English 

versions: use Edit → AutoText to see the one appropriate for your language). 

Typing fn and  F3  will produce a table with one row and two columns, with a Math object on 

the left cell and a variable on the other. 

Both examples show what AutoText does and its use, which is to introduce a document snip 

previously defined in any place using only an abbreviation and a keyboard shortcut. 

 

2.4.1 Inserting an Auto Text 

Insert an AutoText by typing the abbreviation followed by  F3 . 

To view the available abbreviations, you can choose Edit → AutoText (  Ctrl  +  F3 ), but an 

easier method is activating the Insert toolbar. With the toolbar active choose the AutoText 

icon                   . You can now view the AutoText categories and their respective abbreviations. 

 

 

 

 

 

2.4.2 Defining an Auto Text 

1. Select the content you want to use for an AutoText. The content can be anything: 

text, tables, pictures, frames, sections, etc. 
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2. With the content selected, go to Edit → AutoText. 

3. The AutoText dialog box will appear. Provide a name for your entry in the Name box. 

Writer will suggest a shortcut, which you can change. 

4. In the box to the left, choose a category for the entry, where the AutoText will be 

classified. 

5. Select the AutoText button to the right, and select either New (text only) (for the 

AutoText to take on formatting where it is inserted into the document) or New (for 

the AutoText to retain its formatting). 

6. Select Close  to return to the document. 

 

If the AutoText contains a table, it is necessary to select at least one line before 

and one line after the table, otherwise only the content and not the table itself 

will go into the AutoText. 

 

 

 

 

 

 

 

Inside the AutoText dialog box, note the following features: 

 With the option Display remainder of the name as suggestion while typing enabled, 

Writer will suggest an AutoText if you start to type the AutoText name. The 

suggestion will appear in a pop-up box, and pressing ↵ Enter  will insert the AutoText. 

 The Categories...  button allows you to create new categories to classify your 

AutoTexts. 

 Path...  defines where to save the AutoTexts. 
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2.4.3 Editing an Auto Text 

In the AutoText dialog box (Edit → AutoText), you can edit your AutoText entries. 

Select an existing AutoText, and choose the AutoText... button to modify or even eliminate 

the AutoText. 

Selecting Edit, a document will open with the AutoText. Simply make the changes and save. 

The entry will now be available as edited. 

 

The changes will apply only to AutoTexts inserted after the modification, AutoText 
already inserted will not be changed 

 

2.4.4 Print a list of Auto Text 

1. Choose Tools → Macros → Organize Macros → OpenOffice Basics. 

2. In the Macro from list, choose OpenOffice Macros → Gimmicks. 

3. Select AutoText and click  Run . 

4. A list of the AutoText entries will be generated in a new document. You can print this 

document. 

 

2.5. Find and replace text 

You can find text within a document with the Find toolbar, or the Find & Replace dialog box. In 

the Find & Replace dialog box, you also have the ability to: 

 Find and replace words or phrases 

 Find and replace specific formatting 

 Find and replace paragraph styles 

 Use regular expressions to find and replace text 
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The Find toolbar                                 will only allow you to search for and identify specific text or 

phrases. You can find the toolbar docked in the standard toolbar, or by 

choosing View → Toolbars →Find. 

 

Display the Find & Replace dialog box by pressing  Control  +  F  or choosing Edit → Find & 

Replace. 

 

 

 

 

 

 

 

 

 

 

1. Type the text you want to search for in the Search for box. 

2. To replace the text, type the new text in the Replace with box. 

3. To find text, click Find. To replace, click Replace. Choosing Find All will select all 

instances of the text. Selecting Replace All will replace all matches. 

4. You can choose from several search options such as matching case, matching whole 

words, or searching for similar words. 
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2-5.1  Find an replace specific formatting  

To quickly change the format of text from one style to another: 

1. Choose the More Options button to expand the dialog box and view the formatting 

options. 

2. To search for text with specific formatting, enter the text in the Search for box. To 

only search for formatting leave the Search for box empty. 

3. With the Search for box selected, choose Format. 

4. Select the formatting options to include and click OK. 

5. To replace with different text and/or formatting, perform the same actions for the 

Replace with box. 

6. Choose Find, Find All, Replace, or Replace All. 

 

2.5.2 Find and replace paragraph styles 

To quickly change paragraph styles from one style to another: 

1. Choose the More Options button to expand the dialog box. 

2. Select Search for Styles (if you have attributes specified this option is labeled 

as Including Styles). 

3. Select styles from the Search for and Replace with drop down menus. 

4. Choose Find, Find All, Replace, or Replace All. 

 

Note: You can only select one style at a time 

 

2.5.3 Using regular expressions (wildcards) 

Regular expressions (also known as wildcards) are combinations of characters that instruct 

Writer how to search for something. 

1. Choose the More Options button to expand the dialog box. 
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2. Select the Regular expressions option. 

3. Type the search text with the regular expression and the replacement text if any. 

4. Choose Find, Find All, Replace, or Replace All. 

 

Examples of common regular expressions: 

To Find Use Examples 

Any single character . b.d finds bad, bud, bid, bed 

One of the specified characters [xyz] b[iu]n finds bin and bun 

Any single character in this range [x-y] 
[r-t]eed finds reed, seed, and teed (range must 
be in alphabetically ascending order) 

Any single character except the 
characters inside the bracket 

[^x] p[^a]t finds post and pest but not past 

The beginning of a word \<start \<log finds logbook and logistics but not catalog 

The end of a word end\> log\> finds catalog but not logistics 

A paragraph marker $ work as a replacement character, use \n instead 

A line break \n replacement characterserts a paragraph marker 

 

To view a full list of regular expressions, select Help → OpenOffice Help and search for 

regular expressions, choose list of to display the list. 
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2.5.5 Inserting special characters 

A special character is one that is not found on the standard keyboard. For example, ₵ ə Σ ẽ ψ 

are all special characters. 

To insert a special character: 

1. Place the cursor in the document where you want the character to appear. 

2. Select Insert → Special Character for the Special Character dialog box. 

3. Inside the dialog box, choose the character from the available fonts and click OK. 

 

Note: Different fonts include different special characters. Utilize the font selection 

to search for specific characters. 

 

2.5.6 Non breaking spaces and spaces and hyphens 

A non-breaking space (NBSP) or non-breaking hyphen tells Writer to never break lines at that 

spot. A non-breaking space or hyphen can never end or begin an automatically wrapped line. 

Use non-breaking spaces to prevent periods at the end of lines that do not terminate 

sentences, or numbers or bullet-like symbols at the beginning of lines that do not initiate list 

items. Use a non-breaking hyphen to prevent the hyphen from appearing at the end of a line, 

such as in a phone number. 

 

2.6.1 Insert a non-breaking spaces 

Place the cursor between the two words, and press  Control  +  Space . 

 

2.6.1 Insert a non-breaking hyphens 

Place the cursor where the hyphen will appear, and press  ⇧  Shift  +  Control  +  - . 
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2.6.2 En and em dashes 

To use en and em dashes, the Replace dashes option must be checked under  

Tools → AutoCorrect Options. With this option enabled, Writer will replace two hyphens, 

under certain conditions, with the corresponding dash. 

 

In the following table, the A and B represent text consisting of letters A to Z or digits 0 to 9. 

The table describes the different en and em dash options. 

Text that you type: Result 

A - B (A, space, minus, space, B) A – B (A, space, en-dash, space, B) 

A -- B (A, space, minus, minus, space, B) A – B (A, space, en-dash, space, B) 

A--B (A, minus, minus, B) A—B (A, em-dash, B) 

A-B (A, minus, B) A-B (unchanged) 

A -B (A, space, minus, B) A -B (unchanged) 

A --B (A, space, minus, minus, B) A –B (A, space, en-dash, B) 

 

En or em dashes can also be inserted manually through Insert → Special Characters, use 

characters U+2013 or U-2014. 

There are also shortcuts available to insert en or em dashes, that vary per operating system. 
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Operating System En dash shortcut Em dash shortcut 

Windows  Alt  + 0150  Alt  + 0151 

Linux Compose + two hyphens + a period Compose + three hyphens + a period 

Mac  ⌥ Opt  + hyphen  ⇧ Shift  +  ⌥ Opt  + hyphen 

 

2.7. Formatting Paragraphs 

Formatting paragraphs in Writer can be achieved through alignment, justified text, line 

spacing, numbering or bullets, and indenting. These actions can be performed using the 

buttons on the Formatting toolbar. The below image shows the Formatting toolbar with the 

paragraph specific icons displayed. 

 

Note: You can use paragraph styles rather than manually formatting paragraphs, 

especially for long documents. 
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2.7.1 Aligned and justified text 

Text can be aligned to the left, center, or right of the document. The below image shows how 

text appears with the different alignment options. 

 

When using justified text, the last line by default is aligned to the left. You can also align the 

last line to the center, or justify the last line. These options are controlled in the Alignment tab 

from Format → Paragraph 
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2.7.2 Tab stops and indents 

The ruler displays the default and defined tab stops. The tab settings affect the indentation of 

paragraphs. You can manually change the indentation of paragraphs with the Increase Indent 

or Decrease Indent icons, or by using the  Tab ⇆  key. 

Tab and indent settings are discussed in the Ruler section of  Writer's User Interface. 

 

2.8.  Formatting characters 

Formatting characters in Writer can be achieved through adjustments to the font family, font 

weight, font size, or font coloring. These actions can be performed using the buttons on the 

Formatting toolbar. The below image shows the Formatting toolbar with the character 

specific icons displayed. 

 

Note: You can use character styles rather than manually formatting characters, 

especially for long documents. 

 

1 Open the Styles and 6 Italic 12 Font Color 

Formatting Window 7 Underline 13 Highlighting 

2 Apply Style 8 Superscript 14 Background color 

3 Font Name 9 Subscript 15 Open Character Format 

4 Font Size 10 Increase Font dialog box 

5 Bold 11 Reduce Font  
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2.9. Autoformatting text 

Writer will automatically format parts of your document, according to the options selected in 

the AutoCorrect dialog box (Tools → AutoCorrect Options). 

 

Inside the AutoCorrect Options dialog box, the Help button will open and describe the 

selected choice and how to activate the autoformats. 

To automatically format your document with the selected options, select or deselect from the 

submenu in Format → AutoCorrect. 

 

2.9.1 While Typing  

The default option, automatically formats the document while you type. 
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2.9.2 Apply 

After choosing this option, Writer will automatically format the document. 

 

2.9.3 Apply and Edit Changes 

After choosing this option, Writer will automatically format the document and then open a 

dialog box where you can accept or reject changes. 

 

2.9.4 AutoCorrect Options  

Open the AutoCorrect dialog box. 

 

2.10. Using footnotes and endnotes 

Footnotes and endnotes are a type of note that comment on or cites a reference for a 

designed part of the text. Footnotes are printed at the bottom of the page for which they are 

referenced, and endnotes are printed at the end of the document. 

 

2.10.1  Inserting footnotes and endnotes 

Place the cursor where you want the footnote or endnote to appear.  Select  Insert  →  

Footnote/Endnote  or click on the Insert Footnote/Endnote Directly icon           or the Insert 

Endnote Directly icon          from the Insert toolbar (View → Toolbars → Insert). 

 

If you use Insert → Footnote/Endnote, the Insert Footnote/Endnote dialog box is displayed. 

From here you can choose the type of numbering sequence and whether to insert a footnote 

or an endnote. 
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The footnote or endnote will be inserted into the text, and the cursor relocated to the 

footnote or endnote area at the end of the page/document. You can then type the 

footnote/endnote content in this area. 

 

To delete a footnote or endnote, simply delete the appropriate marker. The contents of the 

footnote/endnote will be automatically deleted and the numbering of the other footnotes and 

endnotes is adjusted automatically. 

 

2.10.2 Defining the format of footnotes and endnotes 

To format footnotes or endnotes, select Tools → Footnotes/Endnotes. Choose from 

numbering and styles settings and click OK. 
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2.11. Checking spelling and grammar 

Writer provides a spelling checker that offers two functions: 

 The AutoSpellcheck            checks each word as it is typed and displays a wavy red line 

under misspelled words. When the spelling error is corrected the red wavy line 

disappears.  

 The spelling check             performs a separate spelling check on the document when 

you click on the icon. The spellcheck reviews the document and opens the Spelling 

and Grammar dialog box if misspelled words are found. The spelling check starts at 

the current cursor position and advances to the end of the document. You can choose 

to continue the spellcheck from the beginning of the document. 

 

Additional features of the spelling checker: 

 Right click on a word with the wavy underline 

to open a contextual menu. You can select 

from suggested words and the selection will 

replace the misspelled word. 

 

 Within the Spelling and Grammar dialog box 

you can change the dictionary language by 

choosing from the drop down menu in 

the Text Language field. Add a word to a 

dictionary by selecting a word, click Add and 

choose the dictionary to add it to. 
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 For more spelling check options, click Options in the Spelling and Grammar dialog 

box. You can choose from several options including whether to check uppercase 

words or words with numbers. You can also manage your dictionaries, add or delete 

dictionaries and add or delete words in your dictionaries. 

 

 

 

 

 

 

 

 

  

Writer does not include a grammar checker but you can install an extension such as the 

LanguageTool. 
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2.12. Using built-in language tools 

The document language determines the dictionary used for spellcheck, thesaurus, and 

hyphenation, as well as the decimal and thousands delimiter and the default currency format. 

Within the document you can apply a separate language to any paragraph style. This 

language has priority over the language for the whole document. You can also assign a 

language to selected pieces of text in a paragraph, by direct formatting or character style. This 

language has priority over the paragraph style and document language. 

Writer provides some tools that allow you to mix multiple languages within the same 

document, or easily switch languages for your documents. This can be accomplished through: 

 Language settings in Options 

 Paragraph and character styles 

 Using the Tools → Language menu 

 Using the status bar 

 

2.12.1 Using language settings in Options 

Using the language settings in Options allows you to set the language of the whole document. 

1. Select Tools → Options and go to Language Settings → Languages. 

2. Under Default languages for documents, select the document language (this will be 

applied to newly created documents). 

3. If you want to change the language for the current document only, select the For the 

current document only option. 
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2.12.2 Using paragraph and character styles 

Selecting a language for paragraph style: 

1. Place the cursor within the paragraph that you want to edit. 

2. Right click to open the context menu and select Edit Paragraph Style. 

3. Inside the Paragraph Style dialog box select the Font tab. 

4. Select the language to use and click OK. 

 

Selecting a language for selected text: 

1. Place the cursor within the text that you want to edit. 

2. Choose Format → Character. 

3. Inside the Character Style dialog box select the Font tab. 

4. Select the language to use and click OK. 

 

2.12.3 Using the tools → Language menu 

You can set the language for the document, paragraph or characters  from  Tools  →  

Language  on the menu bar. 

 

For Selection: Applies language to 

the selected text.   

For Paragraph: Applies language 

to the selected paragraph. 

For all Text: Applies language to 

the entire document. 

 

2.12.4 Using the status bar 

Change the language of the paragraph or the entire document from the status bar. 
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1. Click on the language in the status bar to pop up a menu of choices. 

2. Choosing Reset to Default Language will return the paragraph or entire document to 

the default language set in Tool → Options. 

 

 

2.13. Using synonyms and the thesaurus 

To access a list of synonyms from the context menu: 

1. Select a word, right click to open the 
contextual menu. 

 

2. Under Synonyms will be a submenu of 
alternative words. 

 

3. Click on the word to replace it with the 
selected word in the document. 

 

 

 

To access the thesaurus, which contains a more extensive list of synonyms: 

1. Select a word or phrase. 
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2. Choose Tools → Language → Thesaurus or  Control  +  F7  or right click and choose 

 Synonyms → Thesaurus. 

3. Choose from the words in the dialog box to replace. 

 

 

2.14. Hyphenating words 

You can use hyphenation in Writer automatically (Writer uses hyphenation dictionaries) or 

manually (inserting conditional hyphens where necessary). 

 

2.14.1 Automatic hyphenation 

1. Open the Styles and Formatting window (click on the Styles and Formatting icon   or 

press   Control   +   T. 

2. Under the Paragraph Styles page, right click on Default and select Modify. 

3. In the Paragraph Style dialog box, select the Text Flow tab. 

mailto:educationtransmedia@gmail.com


 

 

 

   
"Transmedia: a new narrative that involves communication and education towards the future classroom”. Code: 2014-1-ES01-KA201-004478 

This project has been funded with support from the European Commission. This publication reflects the views only of the author, and the 
Commission cannot be held responsible for any use which may be made of the information contained therein. 

This work is licensed under a Creative Commons Attribution-NonCommercial-NoDerivatives 4.0 International. Permissions beyond the scope of this 
license may be available at educationtransmedia@gmail.com 

    48 

4. Under Hyphenation, select or deselect the Automatically option, click OK to save. 

 

 

 

 

 

 

 

 

 

 

You can set hyphenation choices through Tools → Options → Languages → Settings - 

Writing Aids in Options near the bottom of the box, scroll down to find the hyphenation 

settings. 

 

To change the minimum number of characters for hyphenation, number of characters before 

a line break, or the number of characters after a line break, select the item and click 

the  Edit  button. 

 

Hyphenation without inquiry specifies that you will not be asked to manually hyphenate 

words that the hyphenation dictionary does not recognize. If this box is not selected, when a 

word is not recognized a dialog box will open where you can manually enter hyphens. 

Hyphenate special regions specifies that hyphenation will be carried out in footnotes, 

headers and footers. 
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2.14.2 Manual hyphenation 

It is recommended to not use a normal hyphen, which remains visible at all times, even if the 

word is no longer at the end of a line when you add or delete text or change formatting. 

Instead it is recommended to use a conditional hyphen. To insert a conditional hyphen inside 

a word, click where you want the hyphen to appear and press  Control  +  hyphen . The 

hyphen will only appear when it is at the end of the line, even if automatic hyphenation is 

turned off. 

 

2.15 Word completion 

The word completion feature in writer tries to guess the word you are typing and offers to 

complete the word for you. If word completion is enabled, you will see the completed word 

highlighted as you type. To accept the suggestion, press  ↵  Enter . Otherwise continue typing 

and the suggestion will disappear. 

To enable or disabled word completion, select Tools → AutoCorrect Options → Word 

Completion → Enable Word Completion. 
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Additionally, you can customize Writer's word completion settings with the following options: 

 Append space: Adds space automatically after an accepted word. 

 Show as tip: Shows the suggested word as a tip (hovering over the word in a box) 

rather than completing the word as you type. 

 Collect words: Collects the words used in word completion when working on a 

document to save for later use in other documents. 

 Accept with: Changes the key that accepts a suggested entry. 

 Min. word length: Changes the length of the smallest words to be remembered. 

 Max. entries: Changes the maximum number of words remembered. 

 Delete entry: Deletes specific entries from the word completion list. 

 

 

 

 

 

 

 

 

 

2.16 Line numbering 

Line numbering adds line numbers in the margin of the document. 
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To enable line numbering, choose Tools → Line Numbering and select the Show 

Numbering option, click OK. 

In the Line Numbering dialog box you can choose the style, format, and position of the 

numbering, as well as the spacing and numbering intervals of the numbering. 

 

 

 

2.17. Tracking changes 

To keep track of changes made in a document you may: 
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 Make changes to a copy of the document, and use Writer to compare the changes 

made between the original and the copy. 

 Enable change marks, that show where you have added or deleted material or 

changed formatting. You can review and accept or reject each of the changes. 

 

2.17.1 Recording changes 

1. Select Edit → Changes → Record. To show or hide the display of changes 

select Edit → Changes → Show. 

2. To include a comment with the change, place the cursor in the area of the change, and 

choose Edit → Changes → Comment. When hovering over the change, a Help 

Tip will display the type of change, the author, date and time of the change. If you 

want a comment to also display in the tip, make sure you have Extended Tips enabled 

(Tools → Options → OpenOffice →General and select Extended tips). 

3. To stop recording changes, select Edit → Changes → Record to deselect the 

tracking. 
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2.17.2  Accepting or rejecting changes 

To accept or reject the recorded changes, you can use the right click context menu, or the 

Accept or Reject Changes dialog box. 

The results of accepting or rejecting changes are: 

 Accepting an insertion removes the marked change color from the inserted text. 

 Rejecting an insertion removes the text from the document. 

 Accepting a deletion removes the text from the document. 

 Rejecting a deletion removes the change indicator and restores the text to the 

document. 

 

Right click context menu 

1. Right click inside a recorded change 

2. In the context menu, choose Accept Change or Reject Change. 

 

Accept or Reject Changes dialog box 

1. Select Edit → Changes → Accept or Reject. This will open the Accept or Reject 

Changes dialog box. 

2. Changes that have not yet been accepted or rejected are displayed. Selecting a 

change in the dialog box highlights the change in the document, so you can see what 

the editor changed. 

3. Choose Accept or Reject to accept or reject the selected change. You can 

choose Accept All or Reject All to accept or reject all changes without review. 

4. To show only the changes made by certain people, or changes made under other 

restrictions, use the Filter tab. Specify filter criteria and return to the List tab to view 

changes. 
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2.17.3 Merging modified documents 

Sometimes multiple reviewers will return the edited version of a document at the same time. 

In this case, you may want to review all changes of the document at once. For this purpose 

you can merge documents in Writer. 

1. Open one of the modified copies. 

2. Choose Edit → Changes → Merge Document. Select another copy of the document 

to merge. 

3. The Accept or Reject Changes dialog box will open, showing changes by one than one 

reviewer. If you want to merge more documents, close the dialog box and repeat step 

2. 

4. All recorded changes are now included in the open copy. To preserve, save this file 

under another name. 

 

2.17.4 Comparing documents 

Sometimes reviewers may not track changes they make in a document. In Writer you can find 

the changes if you compare the documents. You must have the original document and the 

edited document. 
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1. Open the edited document. Select Edit → Compare Document. 

2. Select the original document and choose Insert. 

3. Changes will be marked and the Accept or Reject Changes dialog box will be 

displayed. You can choose to accept or reject changes as described in the above 

section. 

 

2.18. Comments 

Writer provides another type of comments, that appear to the side of the document page, and 

look like "sticky notes". These comments allow authors and reviewers to exchange ideas, ask 

for suggestions or brainstorm during review. 

To insert a comment, place the cursor in the place the comment refers to and 

select Insert → Comment, or press  Control  +  Alt  +  N . The comment will be anchored to 

the reference point by a dotted line, and displayed in a box to the right hand side of the page 

where you can type the text of the comment. 

The comment box will show the author's name and time stamp indicating when the comment 

was created. If more than one person edits the document, each author is allocated a different 

comment background color. 

Clicking on the menu arrow icon of the comment displays a drop-down menu where you can 

delete the current comment, all the comments from the same author, or all the comments in 

the document. Right clicking on the comment gives further options to apply basic formatting 

changes to the comment. 

You can navigate from one comment to another using the Navigator. With the Navigator 

open, expand the comments section and select the comment text to move to the anchor point 

of the comment. You can also edit or delete comments from the Navigator by right clicking on 

the comment text and selecting Comment → Edit or Delete. 
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2.19. Word Count 

Select text and choose Tools → Word Count. The word count dialog box will display the 

number of words and characters in the selection, as well as the number of words in the 

document. 

 

2.20. Changing Case 

To change the case of a selection, choose Format → Change case and choose from the 

following: 

 Sentence case: only the first word is capitalized (and proper nouns) 

 lower case: no words are capitalized (except proper nouns) 

 UPPER CASE: all letters are capitalized 

 Capitalize Every Word: every word is capitalized 

 tOGGLE cASE: changes every letter to the opposite case 

 

 

 

 

 

 

 

 

 

 

mailto:educationtransmedia@gmail.com


 

 

 

   
"Transmedia: a new narrative that involves communication and education towards the future classroom”. Code: 2014-1-ES01-KA201-004478 

This project has been funded with support from the European Commission. This publication reflects the views only of the author, and the 
Commission cannot be held responsible for any use which may be made of the information contained therein. 

This work is licensed under a Creative Commons Attribution-NonCommercial-NoDerivatives 4.0 International. Permissions beyond the scope of this 
license may be available at educationtransmedia@gmail.com 

    57 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Based on https://wiki.openoffice.org/wiki/Documentation/UserGuide/Writer/Page 

 

This work is licensed under a Creative Commons 
Attribution – Non Commercial – No Derivatives 4.0 
International. 

Permissions beyond the scope of this license may be 
available at educationtransmedia@gmail.com 

mailto:educationtransmedia@gmail.com
https://wiki.openoffice.org/wiki/Documentation/UserGuide/Writer/Page
mailto:educationtransmedia@gmail.com

